Flying Thecus has hard landing...

Vendor changes make it unusable with open source OSes

By Ian Darwin on 2007-06-15 01:21 in Category: oss openbsd

The Thecus N2100 sits idle in a corner, because the vendor changed the software in a way that breaks the ability to install most open-source OSes. 

The OpenBSD install, like many others, depends on setting certain firmware commands to be saved in the flash memory, and executed at boot time. This worked nicely on the versions of Thecus that the OpenBSD support was developed for, but in current versions (1.93+, including mine) Thecus modified the firmware to still save these commands, but to ignore them at boot time and use their "standard" ones.  They also removed the source code of previous versions from their web site, making it very difficult for even advanced developers to figure out how to revert this unfortunate change. They have also refused to provide information on how to fix it, saying I must contact my reseller (since I bought it used, there is no reseller).  I have been told that other open source projects are having similar problems, so it's not just OpenBSD that's affected.

Until Thecus changes this code back, so it actually honors the fconfig boot script settings, I can not advise buying this unit. If you want a small standalone unit, consider Soekris instead.
Twitter logo RSS/Atom Feed Icon
Categories Cloud